Google Business Profile Bug Causing Hidden Questions & Answers

Business Owner Outside Store Google Maps Pin

For the past few days there has been a number of complaints about not being able to see Questions and Answers on Google Business Profile listings. While some can see some Q&As, not everyone can see all of the past Q&As posted on those Business Profiles within Google Search.

The Local Search Forums, a few Google Business Profile Help threads, including posts on Threads and X all are talking about the issue.

In short, some are saying they are not able to see previously posted questions and answers on their Google Business Profiles. Some say this includes newly added Q&A posts and some say it includes older ones. I see some old ones on my Business Profile.

Here is a screenshot from the Local Search Forums where Nick Anson wrote:

We’ve recently noticed this when dealing with one of our bigger clients with a lot of locations, for whom we’ve been updating their Q&A’s for a few months now. This has only just recently happened the past couple of weeks, and there seem to be more instances of this bug this week than there were last week (though it isn’t happening to all their listings).

When logged into the Google accounts managing/owning the client’s listings, the Questions and Answers button brings up this “No questions are currently available option.”

It lets us ask a question, but as soon as we do it disappears. Both the newly added questions as well as questions and answers we’ve done in the past (at least most of them) show up in search when not logged into an account associated with the client’s listings and allows users to utilize the feature.

Empty Google Business Profile Qa Bug

Here are some comments in that thread:

I’ve been seeing multiple reports of this from client sites and from a number of folks in GBP Facebook groups.

Same behaviour of being unable to create question or variations like able to create a new Q&A question but then unable to respond to it.

Certainly seems like something’s borked – I’d wait it out for a couple of days before investing any more time in the issue (aside from reporting it).

I’m experiencing this too. I posted questions yesterday to a client’s GBP through the account that manages their profile, and am unable to see them, unless I look at the profile from an account that doesn’t have access. I checked to see if I could answer them using Google’s API, and the questions didn’t show up there either. Was going to wait a few more days before I posted it in the community forum.

Here is a blank Q&A section from one of the posts in the Google forums:

Google Business Profile Hidden Questions Answer

So if you are seeing this, you are not alone.

Update: The API is not working either, which makes sense:

Forum discussion at Local Search Forums, Google Business Profile Help, Threads and X.


source
The article is sourced from the internet. Click the “Source” button to view the original content. If there is any copyright infringement, please contact our team for removal.

Share this article
Shareable URL
Prev Post

SEO In Crisis? Moz Search Scientist Warns Of Challenges Ahead

Next Post

How the Google leak confirms the significance of author and publisher entities in SEO

Read next
Subscribe to our newsletter
Get notified of the best deals on our WordPress themes.